Theppitak's blog

My personal blog.

01 ธันวาคม 2547

Intel Play

โรงเรียนประถมเก่าของผมเดี๋ยวนี้ไฮเทคครับ นอกจากจะมีอินเทอร์เน็ตความเร็วสูงแล้ว ยังมีอุปกรณ์ทดลองวิทยาศาสตร์ทันสมัยอีกด้วย แต่ปัญหาก็คือ ครูยังไม่เชี่ยวชาญกับอุปกรณ์ไฮเทคบางอย่าง มันก็เลยวางไว้ในตู้เฉยๆ จนเมื่อวันก่อน ผมไปอาศัยห้องวิทยาศาสตร์เซ็ตเครื่องเตรียมสอนลินุกซ์ ถึงได้ถูกวานให้ช่วยดู "กล้องจุลทรรศน์ดิจิทัล" ให้หน่อย

มันคือกล้องจุลทรรศน์ Intel Play QX3 สำหรับเด็ก ภายในตัวกล้องมีกล้องวิดีโอต่อออกมาทาง USB port เข้าเครื่องคอมพิวเตอร์ แต่ปรากฏว่า แผ่นซีดีที่มากับกล้องนั้น ให้มาแต่โปรแกรมรุ่นเก่าที่ใช้กับ Win 98/ME เท่านั้น แต่เครื่องที่ใช้มีแต่ Win XP เลยต้องไปดาวน์โหลดรุ่นใหม่มาแทน หลังจากติดตั้งแล้วก็ใช้ได้ทันที เป็นประสบการณ์การใช้กล้องจุลทรรศน์ที่แปลก ไม่ต้องใช้ตาเล็งผ่านรูกล้องเล็กๆ แต่ดูจากจอภาพ คุณครูจะเอามาฉายขึ้นจอใหญ่ให้นักเรียนดูกันทั้งห้องก็ได้ ถ่ายภาพเก็บเอามาพิมพ์ออกกระดาษได้ เอาขึ้นเว็บก็แป๊บเดียว เจ๋งดีแฮะ เห็นแล้วอิจฉาเด็กเลย

พอเซ็ตกล้องได้ ครูหมวดวิทย์เลยขอให้เซ็ตอุปกรณ์วัดอีกตัวนึง เป็น probe สารพัดแบบ ทั้งวัดอุณหภูมิ วัดความสว่าง ตรวจจับการเคลื่อนที่ด้วย ultrasound วัดกระแส/แรงดันไฟฟ้า เป็นตาชั่งวัดแรงกลก็ได้ ฯลฯ ทั้งหมดสามารถต่อผ่านอุปกรณ์ควบคุมอันเดียว ซึ่งมี USB port สำหรับต่อกับคอมพิวเตอร์อีกที ตัวนี้ไม่ใช่ Intel ทางโรงเรียนซื้อมาจากบริษัทที่กรุงเทพฯ ชื่อคุ้นหูมากๆ ;-) แต่ก็วางไว้ในตู้ ไม่เคยได้ใช้เหมือนกัน ก็จัดแจงลงโปรแกรมแล้วเชื่อมต่อจนสำเร็จ ลองทำการทดลองง่ายๆ ดู โอ้ว.. มันยอดมากเลยจอร์จ มัน sampling ค่าตามที่กำหนดเก็บลง spreadsheet แล้วพล็อตกราฟให้เสร็จสรรพ มีฟังก์ชันทำ curve fitting ในตัว คำนวณพื้นที่ใต้กราฟ หาความชัน ฯลฯ คิดว่ามหาวิทยาลัยบางแห่งยังไม่มีอุปกรณ์แบบนี้ด้วยซ้ำ!

เซ็ตเสร็จแล้ว ก็มานั่งนึก ว่าพวกนี้สามารถใช้งานกับลินุกซ์ได้หรือเปล่า อุปกรณ์ probe นี่คงยาก เอาไว้ทีหลัง แต่กล้องจุลทรรศน์นั้น มันคือกล้องวิดีโอดีๆ นี่เอง ซึ่ง เว็บของ Intel Play เอง ก็บอกว่า มีลูกค้าบอกว่าใช้ CPiA driver บนลินุกซ์ได้ เลยตื่นเต้น ลองเข้าไปดูในเว็บ ก็มีข่าวบอกว่า driver ได้เข้าไปใน source ของลินุกซ์ตั้งแต่รุ่น 2.5 แล้ว ก็เลยลองมาคอมไพล์เคอร์เนล 2.6 โดยเปิด Video4Linux และเปิดโมดูล cpia, cpia_usb พร้อมกับโหลดโมดูล "v4l" ใน XFree86 พอเสียบกล้องปุ๊บ dmesg ดู ก็ปรากฏว่ารู้จักอุปกรณ์ lsmod ดูก็เห็น cpia, cpia_usb ขึ้น แต่มาตกม้าตายที่ udev เพราะลองเรียก vlc, xawtv, tvtime ทั้งสามตัวอ่านสัญญาณไม่ได้ บอกว่า เปิด device /dev/video0 ไม่สำเร็จ ลอง ls ดู ก็ไม่เจอ device file ที่ว่า!

เลยชักงงๆ ว่า udev มันผิดปกติอะไร หรือว่า naming convention มันเปลี่ยน? เลยจัดการสั่ง /etc/init.d/udev stop เพื่อ unmount udev เสีย คราวนี้ /dev/video0 โผล่ แต่ก็ยังเปิด device ไม่ได้อยู่ดี จบวันนั้น ยังเชื่อมต่อไม่ได้ ต้องเอากล้องไปคืนก่อน ไว้วันหลังค่อยไปลองใหม่

ตอนนี้ งานที่เร่งกว่า นอกเหนือจากงานสอน คือเว็บโรงเรียน :-P

2 ความเห็น:

แสดงความเห็น (มีการกลั่นกรองสำหรับ blog ที่เก่ากว่า 14 วัน)

<< กลับหน้าแรก

hacker emblem