Theppitak's blog

My personal blog.

10 ตุลาคม 2549

xulrunner-libthai deb

จากที่ได้ backport patch ของ mozlibthai มาที่ 1.8 branch แล้วก็ build ใช้เองจาก CVS เห็นว่าได้ผลดี ก็เลย build xulrunner deb พร้อม mozlibthai component เพิ่มด้วย โดย upload ไว้ที่ LTN APT สามารถติดตั้งได้ดังนี้ (สำหรับผู้ใช้ epiphany):

  • เพิ่มใน /etc/apt/sources.list:
    deb http://linux.thai.net/apt ./
    
  • ติดตั้ง libxul0d และ xulrunner-libthai:
    # aptitude update
    # aptitude install libxul0d xulrunner-libthai
    

แพกเกจดังกล่าว จะมีผลกับ epiphany เท่านั้น ส่วน firefox นั้น คงต้องรอ debian เปลี่ยนชื่อให้เสร็จก่อน (จะได้ไม่ต้อง build เสียเที่ยว) บวกกับว่าผมจะมีแรง build หรือไม่ เพราะเครื่องที่ใช้ค่อนข้างช้า และฮาร์ดดิสก์เหลือที่น้อย อย่าง xulrunner ก็ใช้เวลาปรับ patch สำหรับ debian อยู่ครึ่งวัน ส่วนอีกวันครึ่งรอ build + เคลียร์ฮาร์ดดิสก์

ต้องยอมสละไฟล์ที่ดาวน์โหลดมาไปเยอะอยู่ รวมทั้ง source code ที่ check out มาอีกหลายชุด ลบไปร่วมๆ 1.7 GB ยังแค่ปริ่มๆ ยังขาดขั้นตอน lintian เพราะฮาร์ดดิสก์เต็มพอดี T_T

ส่ง patch ไปที่ debian bug ละ เขาจะรับหรือเปล่าต้องรอดู

ปล. เมื่อไร Thai Firefox Community Edition จะมี Linux version?

2 ความเห็น:

  • 22 พฤศจิกายน 2549 16:48 , Anonymous ไม่ระบุชื่อ แถลง…

    คุณเทพครับ

    ผมใช้ Ubuntu 6.10 CPU : Celeron 2.66
    ได้ทำตามที่แนะนำแล้ว แต่ไม่สามารถ install ได้ครับ
    Error บอกว่า
    quote
    The following packages have unmet dependencies:
    libxul0d: Depends: libfontconfig1 (>= 2.4.0) but 2.3.2-7ubuntu2 is to be installed
    E: Broken packages

    unquote

     
  • 22 พฤศจิกายน 2549 21:07 , Blogger Thep แถลง…

    package นั้น build สำหรับ debian ครับ ไม่ใช่ ubuntu

     

แสดงความเห็น (มีการกลั่นกรองสำหรับ blog ที่เก่ากว่า 14 วัน)

<< กลับหน้าแรก

hacker emblem